Posts filed under ‘GNU/Linux Distributions’

Printer fix after installing Ubuntu 10.10 (Lexmark E120n)

Yesterday I did a fresh install of Ubuntu 10.10 and today when I tried to print out some work I got an unpleasant surprise:

As always Ubuntu found my Lexmark E120n drivers when I turned on the printer, but when I tried to print out my work the it just made it’s usual noises and movements but without grabbing any paper. First I thought that it maybe were broken, but then I remember that I used the printer yesterday with Ubuntu 10.04 and it worked just fine. So I tested it with Peppermint Ice, and later with the Ubutntu 10.04 live CD were it worked like a charm.

So I’m pretty sure this is a Ubuntu 10.10 issue, I don’t know if other than me are affected, anyway this is the fix I found after realizing that I could manually edit the .ppd file:

  1. Download lex120n.txt (it’s an old .ppd file, I just had to change the file name to be able to upload it)
  2. Open “Nautilus” as root (gksudo nautilus)
  3. Goto /etc/cups/ppd
  4. Open the file named Lexmark-E120n.ppd
  5. Copy all the text from lex120n.txt and paste it into  Lexmark-E120n.ppd (after removing all the text of course)
  6. Restart and voilà, the printer works properly again ^^

You can also rename lex120n.txt into Lexmark-E120n.ppd and move it to /etc/cups/ppd instead of copying and pasting.

Thanks to the people that tried to help me at Linuxquestions.org before I found the solution myself :)

Advertisements

11/10/2010 at 20:18 1 comment

Check-list after installing Ubuntu 10.10 – Maverick Meerkat

Tomorrow Maverick Meerkat (Ubuntu 10.10) will arrive, and as usual I’m making a little check-list while I’m waiting :)

Things found in Ubuntu Software Centre that you just need

  1. Ubuntu Restricted Extras (ubuntu-restricted-extras): Gives you all the codecs you need :)
  2. Sun Java (sun-java6-bin, sun-java6-jre): Can only be installed after installing Ubuntu Restricted Extras
  3. Gufw (gufw): Graphic user interface for the firewall in Ubuntu
  4. Wine (wine1.2, wine1.2-gecko): Compatibility layer for running Windows applications
  5. Gnome Format (gnome-format): A tool to easily format (erase and initialize) external memory media like USB sticks or SD/MMC flash cards
  6. ClamTK: GUI for ClamAV – Antivirus (it can be discussed if you need one or not, read more here: Antivirus)
  7. Simple backup suite: Backup software

Misc (found in Ubuntu Software Centre):

  1. GIMP: The GNU Image Manipulation Program
  2. Gmail Notifier
  3. VLC: Media Player that can play almost everything
  4. Adobe Reader I just can’t stand the default pdf-viewer…
  5. Okular: The best pdf-viewer ever! (Why do you need two pdf-viewers you may ask? Because Okluar doesn’t show up in the browser)
  6. PDF-shuffler: Easy pdf editor
  7. Calibre: E-book converter and library management
  8. R Commander: Graphical interface to the R environment for statistical computing
  9. Exaile: In my opinion the best music player for Linux

Must haves, you have to install manually:

  1. Ubuntu Tweak: Makes life much easier (can be used to easily edit the window buttons) :)
  2. Moonlight: A free Silverlight clone
  3. Prey: Open source anti-theft solution for Linux, Mac, PCs & Phones
  4. BleachBit: Kind of like CCleaner for Windows

Misc you have to install manually:

  1. Dropbox For syncing and sharing files. Can be used to share and sync files with Windows, Mac and Linux (Gnome) and smartphones. My favourite <3
  2. Adobe Air and then TweetDeck
  3. Skype
  4. Calibre: E-book converter and library management. I know it’s mentioned above as well, but I prefer the “download”-version.
  5. Kdenlive: Free and open source video editor for GNU/Linux, Mac OS X and FreeBSD

Other things that have to be done:

  1. Enable Compiz Desktop Effects
    Open the Appearance window
    * System > Preferences > Appearance
    * Select ‘Desktop Effects’ Tab
    * Check either ‘Normal’ Or ‘Extra’
  2. Install more fonts by copying this into the Terminal
    sudo mkdir -p /usr/lib/X11/fonts/Type1 && sudo apt-get install msttcorefonts && sudo apt-get install ttf-larabie-straight ttf-larabie-deco mplayer-fonts xfonts-terminus-dos xfonts-terminus xfonts-terminus-oblique xfonts-mona tv-fonts ttf-tuffy ttf-sjfonts ttf-sil-padauk ttf-sil-ezra ttf-paktype ttf-georgewilliams ttf-fifthhorseman-dkg-handwriting ttf-farsiweb ttf-essays1743 ttf-opensymbol ttf-nafees ttf-mgopen ttf-gentium ttf-freefont ttf-dustin ttf-devanagari-fonts ttf-dejavu-extra ttf-dejavu-core ttf-dejavu ttf-bpg-georgian-fonts ttf-bitstream-vera ttf-alee
  3. Remove Computer Janitor from the menu before you get tempted to use it (DO NOT USE IT! Use Ubuntu Tweak or BleachBit instead)
  4. Follow this guide to be able to watch encrypted DVDs in Ubuntu: How to watch encrypted DVDs in Ubuntu?
  5. In general make the system work and look as you want it to ^^

Must have add-ons in Firefox

  • Dictionaries & Language Packs
  • MediaPlayerConnectivity: Allow you to launch embed video of website in an external application with a simple click
  • GBookmarks: Cool application that works together with Google Bookmarks, and saves all you bookmarks on the web, so in that way you can have your bookmarks with your were ever you go
  • Clipmarks: Fun way to bookmark)
  • FireFTP: My favourite FTP-client
  • Adblock Plus: Keeps the adds away
  • FLASH-AID: Remove conflicting flash plugins from Ubuntu Linux systems and install the appropriate version according to system architecture.

09/10/2010 at 22:13 1 comment

Peppermint Linux OS

I fell over a GNU/Linux distribution called Peppermint today, when I was searching after something Linux Mint 9 LXDE (Me and Joliclound 1.0 didn’t work out that well). I haven’t tried Peppermint yet but when I read on their webpage it seems really interesting:

System Requirements:
* i386 or derivative processor (AMD64 and x86_64 are fine as well)
* 192 MB of RAM
* 4 GB hard drive space (this is an overestimate just for good measure)

Under the Hood:
* Pcmanfm 0.9.7
* Openbox 3.4.11.2
* Xorg 1.7.6
* Lxsession 0.4.3

Peppermint is based on Ubuntu 10.04 Lucid Lynx or to be more specific Lubuntu, but it seems like they have used something from Linux Mint as well, and the default desktop environment is LXDE. It’s focusing on cloud computing and wants everything to work out of the box. It comes in two flavours: One and Ice. The only main difference seems to be that One relies on Firefox and Mozilla Prism while Ice uses Chromium as it’s default browser and uses a custom Ice tool to link to cloud applications on the desktop.

Default Installed Applications One: Firefox, Drop-Box, Exaile, Prism, X-Chat and Transmission

Default Installed Applications: Chromium Web Browser, Drop-Box, Xnoise, Ice, X-Chat and Transmission

You can find more information on their webpage: Peppermint Linux

Think I will try it on Vesla (Asus Eee 900) soon, and maybe write you a little review?

A little screenshot from their webpage:

22/08/2010 at 18:51 1 comment

First Look: Jolicloud 1.0

Linux Mint 9 got a little to heavy for my little netbook, Vesla (Asus Eee 900), so right now I’m testing Jolicloud 1.0.

I’ve tested the previous version before, and wasn’t really impressed; it looked like Ubuntu Netbook Edition just with another software installer, and if I had to choose between the two then I would go for UNE.

But when I installed Joulicloud 1.0 it was really different, it no longer looks like a UNE clone, and this screenshot speaks for itself:

From Wikipedia:

Version 1.0 of the operating system incorporates a user interface built with HTML5 that includes an application launcher, a library of compatible applications with one-click installation and removal, a display of all machines associated with user account, and a social activity stream that enables users to compare installed applications. The launcher displays only those applications supported on the library, but that launcher can be viewed from any machine running Jolicloud. Account management is available from any computer with an HTML5-compatible browser.

The installation went nicely, but for some reason Jolicloud really wanted to unmount my hard drive. I also had some trouble with “activating” my netbook on wifi and I had to use a my Ethernet cable to be able to see a drop-down menu that I needed to get it to work (Bad Jolicloud!)… Besides that everything seems to work out of the box on my Asus Eee 900. I’ve also tested it on the Aspire One 751h of a  friend of mine, and it worked out of the box there as well, even though it usually doesn’t play well with GNU/Linux distros. So I have to say that I’m actually really impressed with Jolicloud’s list over compatible devices ^^

When it comes to software I’m missing lot of packages like for example Okular (had to force Jolicloud into accepting in the terminal) and Exaile. It’s also based on Ubuntu 9.10 which means that it won’t Jolicloud wont packages from newer Ubuntu versions like for example Spotify for Linux.

But overall I like it (even if I want more programs and more possibilities for customisation) and since it passed my Dropbox-and-Okular-test, I’m going to try it for some days. So don’t be surprised if you see some Jolicloud updates here in the next few days (for example about how to install Okular in Jolicloud 1.0 :P).

07/08/2010 at 23:11 Leave a comment

Finally: Spotify for Linux!

Yes, you read it right! Right now Spotify is working on a version for Linux users, so hopefully we soon don’t have to rely on Wine to run Spotify any more. And hopefully this will fix the Spotify link issues as well as other functionality that we haven’t been able to use until now ^^

Right now the GNU/Linux Spotify version is in a preview version that’s just available for Spotify Premium subscribers as they “haven’t found a reliable way to display ads yet“.  Users should also note “that there are issues regarding decoding of local music on the Linux platform so we haven’t included support for local files in this version“. It also seems like they are focusing on Debian distributions right now(?).

Why has finally Spotify acknowledged us Linux users? I accentually think this is something we should hank the developers of programs like DEspotify for :)

Installation

  1. Go to Software Sources (Ubuntu: System > Administration > Software Sources)
  2. Then select the Third-Party Software tab
  3. Click on the [+ Add] button and add: deb http://repository.spotify.com stable non-free (be sure to reload/update your sources)
  4. Open the Terminal and write:
    gpg --keyserver wwwkeys.de.pgp.net --recv-keys 4E9CFF4E
  5. gpg --export 4E9CFF4E |sudo apt-key add -
  6. sudo apt-get install spotify-client-qt spotify-client-gnome-support
  7. And yey it’s installed!

As I’m not a premium user myself it would be really cool if people could tell if this installation worked for them, and about the look and feel about the preview version of Spotify for Linux :)

Read more: Spotify for Linux

UPDATE: Spotify for Linux is now also available for Spotify Unlimited subscribers.

12/07/2010 at 13:01 2 comments

How to install Opera in Ubuntu

Some weeks ago a friend of mine asked me how she could install the Opera web browser in Ubuntu as she had problems installing it the regular way. After that I have gotten this question some more times, so I decided to make this little guide.

The Regular Way

  1. Download Opera for your machine from this site http://www.opera.com/browser/download
  2. Install it like any regular package :)
  3. Yey! Your finished!

The Alternative (Terminal) Way

My friend had problems with the regular way of installing Opera and I have heard that there are others with this problem. But you will still able to install it by using the terminal, and this is how you do it:

  1. Go to Software Sources (System > Administration > Software Sources)
  2. Then select the Third-Party Software tab
  3. Click on the [+ Add] button and add:deb http://deb.opera.com/opera/ stable non-free
  4. Now open the terminal and write:wget -O - http://deb.opera.com/archive.key | sudo apt-key add -
  5. sudo apt-get install debian-archive-keyring
  6. apt-get update
  7. sudo apt-get install opera
  8. Yey! You should now have Opera installed on your system ^^

I don’t use Opera myself so please tell me in a comment if these solutions doesn’t work for you. And as usual: Feel free to ask if you have any questions about the installation :)

11/07/2010 at 18:11 Leave a comment

How to watch encrypted DVDs in Ubuntu?

This is one of the questions people often ask me when they are trying Ubuntu for the first time. For in Ubuntu, unlike in Linux Mint (one reasons why I recommend Linux Mint for those who new to GNU/Linux), watching encrypted DVDs doesn’t work right out of the box. This is because this feature is a part of the package repository Medibuntu (Multimedia, Entertainment & Distractions In Ubuntu) that isn’t included into the Ubuntu distribution for legal reasons (copyright, license, patent, etc).

I’m just going into show you how to install the package that let you play encrypted DVDs and not how to add the Medibuntu repository (but if you want to you cant read about how to do that here: Medibuntu.

The GUI Way

  1. Open Synaptic (System >Administration > Synaptic Package Manager ) or Ubuntu Software Centre if you’re using Ubuntu 10.04 (Applications -> Ubuntu Software Centre)
  2. Search for ubuntu-restricted-extras (Ubuntu users), kubuntu-restricted-extras (Kubuntu users) or xubuntu-restricted-extras (Xubuntu users) and install this package
  3. Then search for the package named libdvdcss2 and install it
  4. You should now be able to watch encrypted DVDs on your system :) If you didn’t find libdvdcss2 try the Terminal Way’s step

The Terminal Way:

  1. Open the Terminal:
    Ubuntu: Applications > Accessories > Terminal
    Kubuntu: KMenu > System > Terminal Program (Konsole)
    Xubuntu: Applications menu -> System -> Terminal
  2. Install Ubuntu Restricted Extras with this command:
    Ubuntu: sudo apt-get install ubuntu-restricted-extras
    Kubuntu: sudo apt-get install kubuntu-restricted-extras
    Xubuntu: sudo apt-get install xubuntu-restricted-extras
  3. Then install try to install libdvdcss2 with the command sudo apt-get install libdvdcss2 if it didn’t work try the command below that’s matching your system (if you don’t know which one, try the one for i386).
    i386:

    1. wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu4_i386.deb
    2. sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_i386.deb

    amd64:

    1. wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu4_amd64.deb
    2. sudo dpkg -i libdvdcss2_1.2.9-2medibuntu4_amd64.deb

    PowerPC:

    1. wget -c http://packages.medibuntu.org/pool/free/libd/libdvdcss/libdvdcss2_1.2.9-2medibuntu2_powerpc.deb
    2. sudo dpkg -i libdvdcss2_1.2.9-2medibuntu2_powerpc.deb
  4. And there! You should now be able to watch encrypted DVDs!

And in case someone is wondering: I recommend using VLC for watching DVDs in Ubuntu (you can find it in Synaptic and Ubuntu Software Centre or you can just install it by using this command: sudo apt-get install vlc).

16/06/2010 at 21:24 4 comments

Older Posts


Licensed Under:

Creative Commons LicenseExcept where otherwise noted, content on this site is licensed under a Creative Commons Attribution-Noncommercial-Share Alike 3.0 Unported License.

Tux and GNU are published under the GNU General Public License.

Subscribe

Categories


%d bloggers like this: